« Movable Type のアップグレードで旧プラグインをコピーしない方法 | メイン | 紅白歌合戦 »

2011年12月30日

「Movable Type 5.12」にアップグレードしました[ Movable Type ]

「Movable Type 5.02」から「Movable Type 5.12」にアップグレードしました。小粋空間さんの記事を参考にさせて頂きました。アップグレードに先立って、「Movable Type のアップグレードで旧プラグインをコピーしない方法」を行いました。

アップグレードの手順は、以下のとおりです。

(1)旧バージョンの保存
バックアップのために、フォルダ名を「mt502」にリネームして残しました。
(2)新しいバージョンの導入
新たに「mt」フォルダを作り、そこにファイルをコピーしました。
(3)既存環境から、環境設定ファイル (mt-config.cgi) の引き継ぎ
今までの「mt-config.cgi」そのままコピーして使用しました。
(4)CGIファイルの属性変更
3項でアップロードした各CGIファイル(.cgi)の属性を「755」に変更しました(値はサーバによります)。
(5)アップグレードウィザード実行
「mt.cgi」にアクセスして「アップグレード開始」をクリックします。
(6)プラグインなどの複製
以下のディレクトリから必要なフォルダやファイルをコピーしました。「plugins」のプラグインはコピーが不要ですが、以下のコピーは必要でした。
・mt-static/plugins/追加したプラグイン
・mt-static/support

投稿者 hnakamur : 2011年12月30日 23:22 : [ 編集 ]

エントリータグ

トラックバック(0)

このブログ記事を参照しているブログ一覧: 「Movable Type 5.12」にアップグレードしました

このブログ記事に対するトラックバックURL: http://nakamura-hiroshi.com/mt/mt-tb.cgi/9363

コメント(2)

アイルのレンタルサーバーをつかっていますが、
Movable Type を5.02→5.12にアップグレードしたところ、
mt.cgiにアクセスする際に、下記のようなエラーが発生しました。

パスmt.cgi script produced no output

もし解決方法をご存知でしたら教えてください。

私は、さくらインターネットを使っていますが、
特に問題は発生しませんでした。
お役に立てませんが、悪しからず。

コメントする